Newsflash

OBS! AVIATE 3.5 users. Please do not use your old password for AVIATE 4 PRO. You will not be able to get updates unless you register your copy of AVIATE 4 PRO via the link shown when you first start the program. If you failed to do that please send me an e-mail so I can fix your registration.

Home FAQ General Can I run AVIATE 4 PRO under Win98?
Can I run AVIATE 4 PRO under Win98?
Written by Anderz Forzelius   
Monday, 01 September 2008 07:12
No, you can only run AVIATE 4 PRO under Windows 2000, 2003, XP and Vista.
Last Updated on Wednesday, 21 November 2018 20:38